Unable to get the sparkfun qwiic working

Hi There,

I am following the tutorial here …

https://dev.blues.io/get-started/tutorials/sensor-tutorial/sparkfun-qwiic-cellular/artemis-thing-plus/arduino-wiring/

For the sparkfun carrier with notcard and artemis mcu.

Talking to the notecard directly is working fine and I can transmit data. Hooking up to the artemis via the qwiic connector and powering from PC via the artemis usb-c (and for good measure separate power to the notecard just in case that was the issue).

This is the arduino sketch

#include <Notecard.h>

#define serialDebug Serial

#define productUID "uk.org.digicatapult.pat.molloy:sparkfunqwiic"

Notecard notecard;




void setup() {
  // put your setup code here, to run once:

  delay(2500);
  serialDebug.begin(115200);

  notecard.begin();
  notecard.setDebugOutputStream(serialDebug);

  J *req = notecard.newRequest("hub.set");
  JAddStringToObject(req, "product", productUID);
  JAddStringToObject(req, "mode", "continuous");
  notecard.sendRequest(req);

}

void loop() {
  // put your main code here, to run repeatedly:

}

Serial monitor is returning

09:37:35.233 -> notecard not responding
09:37:35.233 -> notecard not responding
09:37:35.280 -> notecard not responding

Is there a step messing somewhere? Seems the artemis is not talking to the notecard down the i2c interface …

Thanks!

Pat

Hey @patmalloy, thanks for the question, and welcome to the community! Sorry to hear you’re having issues getting the Artemis to talk to the Notecard. I have that board and the Qwiic carrier, so I’ll take a look and see if I can spot the issue.

Incredibly kind. Thanks!

Hey @bsatrom, any luck with this?

I’ve actually tried with a couple of other sparkfun qwiic enabled boards (e.g. SparkFun Thing Plus - SAMD51 - DEV-14713 - SparkFun Electronics) but cannot get those to play nice either.

Making me think there is something amiss with the quiic notecard carrier?

Pat

Hi @patmolloy not yet, no. We are still investigating. I actually think it might be an issue with the Note-Arduino library and the Wire implementation that SparkFun uses by default, but I need to dig deeper. Thanks for trying on a SAMD51 as well! I was wondering if it was an Apollo/Artemis issue, but it would seem to not be the case.

Actually on the SAMD51 I get no output on the serial debug at all! I’ll try some other qwiic boards too - I have one based on the new RPi2040 but I have a feeling that is going to be trouble!

Ok, just a bit more info. Today I received a sparkfun ESP32 Thingy Plus board (with qwiic) and this does work. Exactly the same script. I see the correct chatter/handshakes in the serial debug window. So it looks like the carrier board does actually work and the notecard worked all along, of course. Not sure if that helps, actually.