Dashboard Status Color Rules

Not a problem, but a question…One of my Notehub Projects has a yellow status indication on the dashboard yet the notecard device is connected with events occurring on Notehub. The project does included a previous notecard (which has a setting of “disabled”). What is the threshold for the dashboard status to show as “green”?

Hi @JimM,

You should see a “green” section on the Notehub project dashboard if the device was active within the last 24 hours:

image

If you have two devices connected to a project, this chart should be split (green and grey presumably).

Rob

Hi @RobLauer , If GREEN indicates activity within last 24 hours, then my YELLOW dashboard symbol should be GREEN? Screen Shot 2021-09-20 at 5.52.19 PM. I have several events daily including today. Here is one example:

. Here is the listed on-line status showing on-line now. Screen Shot 2021-09-20 at 5.56.42 PM
. It is just the color code on the dashboard circle symbol that seems incorrect?

Yeah this does seem incorrect. Can you do me a favor and mouse over the grey and yellow bands and see what the pop-up window says for both?

@RobLauer,
Fresh event:


Dashboard Status (after page refresh):Screen Shot 2021-09-21 at 9.39.33 AM
Inactive Notecard on same project:
Screen Shot 2021-09-21 at 9.40.21 AM

BTW, I see the timestamp is using British Time but event is EDT, where I am located?

Your troubleshooting guidance is appreciated! (Greg Wolff is a viewer on this project and I can give you access also if you have time and interest to dig into the details).

A quick comment on the Time.

All of the Notecards and Notehub use UTC for Timestamps. And given that the devices could be just about anywhere in the world, if we count “number of active devices today”, the question arises, “when should today start and end”? Or “when should a month start and end”?

So it uses UTC to define the start/end of a time period for counting devices. While the same is true on the events data, there is a feature on the “Events” page that transforms the timestamp to your local date.

You can click on the “Current Date” button on the lower left of the “Events” page to cycle through the timestamp display options

image

For the high-level indicator on the Projects page, we did leave it to be UTC to define the reference point precisely when the count starts/ends. If you think there it is important to have this consistent with the events page, I think that’s something we can consider. Though, the date displayed will be a little “off”

Hypothetically if Notehub Projects page did have this feature, in the example above it would be 08/21 EDT, though the Events page could still potentially show events from 08/21. This would appear to contradict the statement that no events occurred before 08/21. But would be an artifact of the difference between local time and the benchmark UTC time. The concern here is this would create more confusion than explicitly stating the benchmark date in UTC on the high-level indicator.

We are of course happy to hear your thoughts on the time display.

So I think Greg explained this well, and it looks like when I view the project I do see the device as active:

1 Like

@RobLauer , @gwolff ,
Thanks Greg for commenting! I think the Dashboard status is fine (it clearly states UTC time as you mention). I also like that EVENTS can toggle between three formats and shows local time.
Now, for the first time in days, my Dashboard status does show GREEN! However, in scanning my EVENTS list, events are occurring more often than one every 24 hours, yet the status wheel was yellow for several days at least until very recently (less than an hour ago?). Am I misunderstanding UTC time?

Yeah this is interesting as it should’ve been green the entire time based on your data. I’ve submitted a bug report internally and will update here as we have more to share. Thanks for the report!

1 Like

@RobLauer , thanks for the “sanity check”. If actually a bug, I am glad to have identified it and will await the findings from the bug reporting. BTW, the notecard is connected in “continuous” mode, if that makes a difference. Cheers!