Cannot connect Notecard to Raspberry Pi 4

I am so confused with the instruction at Quickstart - Blues Wireless Developers. I plug the Notecarrier-Pi into the 40-pin header of my Raspberry Pi, I opened the browser on Raspberry Pi, but it says Unsupported Browser. I downloaded notecard cli and it says error opening serial port: serial device not available. I used a USB cable to connect the notecard to a PC, still not connected.

Hi @sandra,

Sorry to hear about your struggles. It can be a bit of a confusing experience to use the Notecarrier-Pi with a Raspberry Pi…and adding a separate PC just to use the in-browser terminal.

I have a couple suggestions for you though:

  1. If you do NOT want to use a separate PC (Mac/Windows/Linux) you can use the Notecard CLI. Instead of communicating with the HAT over serial (as you tried), you can communicate with it over I2C. To do so you just need to issue this command: ./notecard -interface i2c. Then verify connectivity with: ./notecard -commtest.

  2. If you DO want to use the in-browser terminal (provides a really nice experience, especially for the quickstart) you have to use a browser that supports the Web Serial API (unfortunately Chromium on the Pi doesn’t support this yet) on a separate PC. You mentioned connecting a PC via USB, which is great, but I would suggest trying a different cable as you need one that supports data transfers (many cheap cables are charge-only).

Note that of course the Notecarrier-Pi functions on its own without a separate PC. I recommend taking a look at the sensor tutorial and some of our Raspberry Pi example projects on Hackster.

Thanks,
Rob

3 Likes

Thank you for your reply. I am able to connect to the Notecard using I2C now!

2 Likes